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Appendix 1: Random Plots Workbook:  
Stratified Sample

These instructions will help users of all skill levels create a random sample of i-Tree Eco 
plot centers, plot areas, and the associated i-Tree Eco-required data files for their study 
area. ESRI ArcGIS software with the Spatial Analyst extension is used.  The instructions are 
generic and applicable with modification to different versions of ArcGIS as well as other GIS 
software in terms of basic operations. The sample plots are stratified by land cover type 
(not by land-use data collected in the field). For purposes of example, 2001 USGS National 
Land Cover Database (NLCD) data are employed as these strata.These instructions are 
composed of four basic steps:

1  Prepare project area data

2  Prepare strata (land cover types) 

3  Generate sample plots

4  Create Eco-ready output

When you are finished, you will have created the following:

•  Area-of-interest (AOI) polygon map layer.

•  Land cover map layer conforming to the AOI boundaries and composed of singular, 
multi-part land cover polygons with Eco-required fields added and populated.

•  Random sample plot centers point map layer with Eco-required fields added and 
populated. 

•  Sample plot areas polygon map layer. 

•  Eco-ready Strata Area text file.

•  Eco-ready Plot List text file.

•  Eco-ready Projection prj file.

Tips

•  The Spatial Analyst extension for ArcGIS is required.

•  Field names and types are important.

•  Obtain projection system and map unit information from the map data provider first.

•  All map data must have valid projection information for proper alignment.
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•  Strata map data must be in a projection system that uses feet or meters – NOT 
degrees.

•  Final Eco-required map units will be metric.

•  AOI examples are polygons such as a city boundary, park areas, or management 
zones. 

•  ESRI shapefiles are easiest to use.

•  “Pin” open ArcToolbox when starting – pushpin icon, upper right of ArcToolbox 
panel.

•  Practice good file management: folders to hold copies of original data, folders to 
hold output, employ logical file naming, etc.

•  ArcGIS should add the geoprocessed map layers to the view automatically. If not, 
use the File > Add Data > Add Data… menu to load them.

•  Temporarily turn off any web browser pop-up blockers.

•  Decide in advance the number of plots for each stratum.

Project Area Data Preparation

Overview

•  Obtain a GIS map layer representing the area-of-interest (AOI) polygon(s) for your 
project area.

•  Launch the ArcMap application of ArcGIS.

•  Load the AOI map layer into the data view.

•  Define the projection/coordinate system of the AOI if needed.

Detailed instructions

1  	Obtain an area-of-interest (AOI) polygon from your GIS Department or an online 
resource. Several options can be found here: http://www.esri.com/data/free-data. 

2  	Launch ArcMap and save your project with an appropriate name at a new location 
via the File > Save As menu. Save periodically while working to avoid data loss.

3  	Use the File > Add Data > Add Data… menu to browse to and load the AOI 
polygon map layer to the current view. 

a  	If your data are properly projected, ArcGIS should handle projection 
differences between the AOI and subsequent map layers on-the-fly.

http://www.esri.com/data/free-data/index.html


69	

b  If your data lack projection information, an “Unknown Spatial Reference” 
message may appear. Click OK to move past it and use ArcToolbox to 
define the projection of the AOI map layer according to your data provider’s 
specifications.  
 
Navigate to ArcToolbox > Data Management Tools > Projections and 
Transformations > Define Projection and complete the Define Projection 
form: 
 
For Input Dataset, choose the AOI map layer from the drop-down list.
 
For Coordinate System, click the Properties button to the right. In the 
Spatial Reference Properties window that appears, click Select and 
choose the coordinate system indicated by your data provider.

Results

An area-of-interest (AOI) polygon map layer: The AOI polygon map layer is now ready 
to be used to clip the strata layer.

Strata Preparation

 Overview

•  Obtain a land cover GIS map layer encompassing the entire AOI.

•  Convert the land cover data to polygons, if needed.

•  Clip the land cover polygon data to the AOI area.

•  Select each land cover category and give it a plain text strata name in the attribute 
table.

•  Dissolve the land cover polygons into a single, multi-part polygon for each land 
cover strata chosen for your i-Tree Eco project.

•  Add Eco-required fields and calculate appropriate values for them.

Detailed instructions

Begin by obtaining land cover data from the Multi-Resolution Land Characteristics 
Consortium (http://www.mrlc.gov/):

1  Launch the MRLC Consortium Viewer; note the available user instructions.

2  Zoom and pan to your AOI, making sure you cover the entire AOI, plus a bit more.

3  Click on the Download tab at upper right, and make sure only Land Cover for a 
desired year is checked. 

www.mrlc.gov
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4  Use the Download tool button to delineate a square area on the map, and in the 
resulting pop-up window, click the Download button to save the layer.  It may take 
a few moments before the web browser’s file save window appears.

5  Unzip the download file to your desired folder. The downloaded NLCD file is named 
numerically and consists of image (raster) data. The file is composed of pixels, and 
each pixel contains information such as a Land Cover code number. A metadata 
file describing the layer’s Entity and Attribute information is included as well. 
Specific land cover category codes and names can be found within.

Use ArcToolbox to convert the land cover image data to polygons.

1  Load the Land Cover image into ArcMap. ArcGIS should reproject these data 
on-the-fly, so they should appear underneath your AOI.

2  Right-click the image map layer and Open Attribute Table to examine the Land 
Cover codes.

3  Navigate to ArcToolbox > Conversion Tools > From Raster > Raster to 
Polygon.

4  Fill out the Raster to Polygon form:

a  For Input Raster, choose your land cover map layer from the drop-down 
menu.

b  For Field, select the field containing the land cover values (refer to 
metadata documentation if necessary).

c  Under Output Polygon Features, use the Browse button to locate a 
suitable location and create a filename for the resulting polygon map layer.

d  The Simplify polygons box should be UNCHECKED.

e  Click OK.

Use ArcToolbox to clip the land cover polygon map layer by the AOI map layer.

1  Navigate to ArcToolbox > Analysis Tools > Extract > Clip.

2  Complete the Clip form:

a  Under Input Features, select the land cover polygon map layer from the 
drop-down list.

b  Under Clip Features, choose the AOI map layer from the drop-down list
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c  Under Output Feature Class, use the Browse button to navigate to a 
suitable location and choose a file name for the resulting map layer.

d  Leave the XY Tolerance field and the units dropdown blank.

e  Click OK.

3  The land cover map layer should now conform to the inside of the project area 
boundaries.

Use ArcToolbox to add Eco-required fields to the clipped land cover polygon map layer.

1  Navigate to ArcToolbox > Data Management Tools > Fields > Add Field.

2  Complete the Add Field form:

a  Under Input Table, select the clipped land cover map layer from the drop-
down list.

b  For Field Name, enter:  StratDslv

c  For Field Type, select TEXT from the drop-down list.

d  Skip the following fields: 

Field Precision

Field Scale

Field Length

Field Alias

Field is Nullable

Field is Required

Field Domain

e  Click OK.

Use regular Selection Queries and ArcToolbox to create text values equivalent to the land 
cover categories for the clipped land cover polygon map layer.

1  Examine the metadata documentation file that downloaded with the NLCD Land 
Cover data. Each GRIDCODE value corresponds to one land cover category. Use 
the GRIDCODEs to decipher the land cover data.

2  In the main ArcMap menu bar, choose Selection > Select by Attributes.
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3  Complete the Select by Attributes form:

a  For Layer, select your clipped land cover map layer.

b  For Method, select Create a new selection and format the queries in the 
SELECT * FROM box at the bottom

c  Make sure the box is empty. Delete old queries if necessary.

d  Double-click the “GRIDCODE” field name from the list above. 

e  Click the equals button.

f  Click the Get Unique Values button.

g  Double-click the first land cover GRIDCODE value in the list.

h  A properly formatted query will look like this: “GRIDCODE”=11.

i  Click Apply – this keeps the selection form open.

4  With features in this first land cover category selected, use ArcToolbox to give the 
land cover category a text name. Navigate to ArcToolbox > Data Management 
Tools > Fields > Calculate Field.

5  Complete the Calculate Field window:

a  Under Input Table, select the clipped and dissolved land cover polygon 
map layer from the drop-down list.

b  For Field Name, select StratDslv from the drop-down list.

c  Under Expression, enter an appropriate name to describe the land cover 
type, for example:  “Developed High Intensity” (including quotes)

d  Skip Expression Type.

e  Skip Code Block.

f  Click OK.

6  Right-click the clipped land cover polygon map layer in the map layers list, select 
Open Attribute Table, and verify that only those selected feature records were 
populated with the appropriate land cover category text. 

7  Repeat steps 1–6 for each land cover category present in the land cover polygon 
map layer. Tip: you can formulate queries to select more than one land cover 
code to group them as a single strata if desired. e.g. “GRIDCODE”=21 OR 
“GRIDCODE”=22.
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8  From the main Selection menu, choose Clear Selected Features to unselect all 
land cover features.

Use ArcToolbox to dissolve the land cover polygon(s).

1  Navigate to ArcToolbox > Data Management Tools > Generalization > 
Dissolve.

2  Fill out the Dissolve form:

a  Under Input Features, choose the clipped land cover polygon map layer 
from the drop-down list.

b  For Output Feature Class, use the Browse button to navigate to a suitable 
location and create a file name for the resulting map layer.

c  Under Dissolve_Field(s), check the StratDslv field (whose attribute values 
hold your names for the NLCD land cover values as described above).

d  Leave the Statistics Field(s) blank.

e  The box next to Create Multipart Features should be checked.

f  Skip the Unsplit lines checkbox.

g  Click OK.

3  Right-click the new dissolved Land Cover polygon layer, Open Attribute Table and 
verify that there are now single, multipart polygons for each land cover category.

Use ArcToolbox to add additional Eco-required fields to the dissolved land cover polygon 
map layer.

1  Navigate to ArcToolbox > Data Management Tools > Fields > Add Field.

2  Complete the Add Field form:

a  Under Input Table, select the dissolved land cover map layer from the 
drop-down list.

b  For Field Name, enter:  Strat_ID

c  For Field Type, select LONG from the drop-down list.

d  Skip the following fields: 

Field Precision

Field Scale
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Field Length

Field Alias

Field is Nullable

Field is Required

Field Domain

e  Click OK.

3  Repeat the steps above as follows for these additional fields:

a  Field Name:  Strat_Area with Field Type: Select DOUBLE.

b  Field Name:  Strata with Field Type: Select TEXT.

Use the attribute table Field Calculator to populate values for the Eco-specific fields added 
to the dissolved land cover polygon map layer:

1  Right-click the land cover map layer and select Open Attribute Table.

2  Right-click the Strat_ID field column heading and select Field Calculator...

a  In the large text entry box below Strat_ID =, enter:  [FID]+1 

b  Click OK.

3  Repeat for the Strata field.

a  In the large text entry box below Strata =, enter: StratDslv

b  Click OK.

4  Right-click the Strat_Area field column heading and select Calculate Geometry…

5  For Property: choose Select Area. If this is not available, your land cover polygon 
map layer is not in a projection system using feet or meters; the section above 
called Project Area Data Preparation.

6  For Coordinate System choose Use coordinate system of the data source.

7  For Units, select Hectares [ha]

8  Close the Attribute Table when finished.

Results

A converted, clipped, and dissolved polygon land cover map layer with Eco-
required fields added and populated.
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•  It should align with and conform to the project area boundaries.

•  It should have ONE record representing EACH land cover category present in its 
table. 

•  The processed land cover polygon map layer is now ready to be used for plot 
generation.

Sample Plot Generation

 Overview

•  Select each land cover category and run the Create Random Points tool from 
ArcToolbox for each land cover category.

•  Merge the resulting random plots data together.

•  Spatially join the land cover data to the random plots data.

•  Add Eco-required Fields to the random plots data.

•  Calculate field values for the random plots data.

•  Buffer the random plots point data to form plot areas.

Detailed instructions

Use regular selection queries and ArcToolbox to select an individual land cover category 
and then generate the desired number of plots for it.

1  From the Selection menu, choose Select by Attributes.

2  Fill out the Select by Attributes form:

a  Under Layer, ensure that the dissolved land cover map layer is selected.

b  For Method, select Create a new selection and format the queries in the 
SELECT * FROM box at the bottom as follows:

c  Make sure the box is empty. Delete old queries if necessary.

d  Double-click the Strata field name from the list above.

e  Click the equals button.

f  Click the Get Unique Values button.

g  Double-click the first land cover Strata value in the list.

h  A properly formatted query will look like this: “Strata”=’Developed, High 
Intensity’.
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i  Click Apply.

3  Navigate to ArcToolbox > Data Management Tools > Feature Class > Create 
Random Points.

4  Complete the Create Random Points form:

a  For Output Location, browse to and single-click your working folder to 
select it and click Add.

b  For Output Point Feature Class, type in an appropriate name with a .SHP 
extension. (Sample plots will be created for individual land cover categories 
as separate map layer shapefiles. Choose a name for each file that reflects 
the category as they will eventually be merged together into one sample 
plots layer, e.g.,  plots_Developed_HighIntensity.shp)

c  For Constraining Feature Class, select your clipped and dissolved land 
cover map layer.

d  For Number of Points [value or field], enter the desired number of sample 
plots for this selected land cover.

e  Skip the remaining inputs.

f  Click OK.

g  Repeat steps 1–4 for each land cover category.

5  From the Selection menu, choose Clear Selected Features to unselect all land 
cover features.

Use ArcToolBox to merge the individual land cover category random plots map layers 
together:

1  Navigate to ArcToolbox > Data Management Tools > General > Merge. 

2  Complete the Merge form:

a  FIRST, you must enter Output Dataset with a file extension of SHP. Click 
the Browse button to navigate to a suitable location and enter a file name 
for the resulting map layer, e.g., SamplePlots_Merge.shp

b  Then, from the drop-down list under Input Datasets, select each land cover 
plot layer, one at a time.

c  Skip the Field Map option.

d  Click OK.
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Perform a spatial join between the merged sample plots point map layer and the dissolved 
land cover polygon map layer. This step assigns land cover types to the sample plot 
points.

1  Right-click the merged sample plots layer and select Joins and Relates > Join...

2  Complete the Join Data form. 

a  Under What do you want to join to this layer? select Join data from 
another layer based on spatial location.

b  Under Choose the layer to join to this layer… select the dissolved land 
cover polygon layer. 

c  Under Each point will be given all the attributes of the polygon that: 
click the button next to it falls inside.

d  Under The result of the join will be saved into a new layer, use the 
Browse button to navigate to a suitable location and choose a file name for 
the resulting map layer. These will be the final i-Tree Eco plot centers.

e  Click OK.

Use ArcToolbox to add Eco fields to the spatially joined sample plots point map layer.

1  Navigate to ArcToolbox > Data Management Tools > Fields > Add Field. 

2  Complete the Add Field form. 

a  For Input Table, select the spatially joined sample plots point map layer 
from the drop-down list.

b  For Field Name, enter:  ID 

c  For Field Type, select LONG from the drop-down list.

d  Skip the following fields: 

Field Precision

Field Scale

Field Length

Field Alias

Field is Nullable

Field is Required

Field Domain
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e  Click OK.

3  Repeat the steps above as follows for these additional fields:

a  Field Name:  LCCode  with Field Type: Select SHORT.

b  Field Name:  X_Coord with Field Type: Select DOUBLE.

c  Field Name:  Y_Coord with Field Type: Select DOUBLE.

Use the attribute table Field Calculator to populate values for the Eco-specific fields added 
to the spatially joined sample plots point map layer in the steps above.

1  Right-click the spatially joined sample plots point map layer and select Open 
Attribute Table.

2  Right-click the ID field column heading and select Field Calculator...

a  In the large text entry box below ID =, enter:  [FID]+1

b  Click OK.

3  Repeat for the LCCode field.

a  In the large text entry box below LCCode =, enter:  [Strat_ID] 

4  Right-click the X_Coord field column heading and select Calculate Geometry…

a  For Property: select X Coordinate of Point

b  For Coordinate System choose Use coordinate system of the data 
source

c  For Units, select Meters [m]

d  Click OK.

5  Right-click the Y_Coord field column heading and select Calculate Geometry…

a  For Property: select Y Coordinate of Point

b  For Coordinate System choose Use coordinate system of the data 
source

c  For Units, select Meters [m]

d  Click OK
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6  To verify the attributes have been correctly modified in the sample plots point map 
layer, right-click the spatially joined sample plots point map layer in the map layers 
list, and choose Open Attribute Table.

a  Scan through the fields and their values to verify they are correct.

(Optional) Use ArcToolbox to buffer the spatially joined sample plots point map layer. This 
step creates the plot of your desired survey size around the plot centers and can be used 
to make field data collection plot maps.

1  Navigate to ArcToolbox > Analysis Tools > Proximity > Buffer.

2  Complete the Buffer form:

a  Under Input Features, select the spatially joined sample plots point map 
layer from the drop-down list.

b  For Output Feature Class, use the Browse button to navigate to a suitable 
location and choose a file name for the resulting map layer.

c  For Distance, in the Linear Unit box, enter the distance value from the list 
below, based on your desired plot size. (The distance is the radius of the 
plot.)

Feet:
For 1/5 acre plots: enter: 52.66

For 1/10 acre plots: enter: 37.24

For 1/20 acre plots: enter: 26.33

For 1/100 acre plots: enter: 11.78

Meters:

For 1/5 hectare plots: enter: 25.23

For 1/10 hectare plots: enter: 17.84

For 1/20 hectare plots: enter: 12.62

For 1/100 hectare plots: enter: 5.64

d  Select Feet or Meters as appropriate from the units dropdown

e  Skip the following entries:

Side Type

End Type

Dissolve Type

Dissolve Field(s)
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f  Click OK.

3  The buffered sample points layer is added to the map view automatically; zoom 
in to examine individual plot areas. Note: choose an equal-area appropriate 
projection system in the layers data view properties if your plot areas appear not to 
be circular.

Results 

Sample plots point map layer

•  User-defined number of plots randomly spread throughout each stratum (land 
cover category)

•  Plot points assigned with land cover categories

•  Eco-required fields added and populated

(Optional) Sample plot areas polygon map layer

Create Eco-ready Output

 Overview

•  Export select fields from the Plot attribute table to a text file.

•  Export select fields from the Strata polygons attribute table to a text file.

•  Copy and rename the AOI projection file.

Detailed instructions

1  From the Selection menu, choose Clear Selected Features if available to 
unselect all features.

2  Right-click the spatially joined sample plot centers point map layer in the map 
layers list and select Open Attribute Table. 

a  Right-click the FID field and select Turn Field Off.

b  Repeat for all but the ID, LCCode, X_Coord, and Y_Coord fields (added in 
Sample Plot Generation above).

c  Under the upper left Table Options drop-down button, select Export.  

d  Browse to a folder where you wish to save the output file.

e  For Save the file as type select Text File.
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f  Name the export appropriately, such as “myEcoPlots_mmyyyy.txt”.

g  Click No when asked to add the new table to the current map.

3  Open the text file in a simple editor such as Windows Notepad (avoid using word 
processing software due to formatting issues).

a  	Use the Search and Replace function to replace each comma with a 
space.

b  Save the file

c  Delete the first line containing the field names: “ID”,”LCCode”,”X_
Coord”,”Y_Coord”

d  Copy and paste these two lines at the top of the file:  
 
$ U4PLLS! 1.3 20040728 1549 
1

e  A properly formatted file will look like this:

$U4PLLS! 1.3 20040728 1549
1
1 1 1199094.600650 2095374.121430
2 1 1202999.760510 2094522.116280
3 1 1207382.288000 2096877.180300
4 1 1198150.473980 2101783.086320
...

4  Right-click the dissolved land cover polygon layer in the map layers list and select 
Open Attribute Table.  

a  	Right-click the FID field and select Turn Field Off.

b  Repeat for all but the Strat_ID, Strat_Area, and Strata fields (added in 
Strata Preparation above).

c  Under the Table Options drop-down button, select Export. 

d  Browse to a folder where you wish to save the output file and save as a 
Text File. 

e  Name the export appropriately, such as “myEcoStrata_mmyyyy.txt”.

f  Click No when asked to add the new table to the current map.
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5  Open the text file in a simple editor (avoid using word processing software).

a  Use the Search and Replace function to replace each comma with a 
space.

b  Save the file.

c  Delete the first line containing the field names: “Strat_ID”,”Strat_
Area”,”Strata”

d  Copy and paste these two lines at the top of the file:  

$U4STAR! 1.3 20040728 1549
1

e  A properly formatted file will look like this:

$U4STAR! 1.3 20040728 1549
1
1 15138.785733 “Developed”
2 3187.141038 “Open”
3 217.131072 “Other”
... 

6  Make a copy of the PRJ file associated with your dissolved land cover polygons 
layer. 

a  In Windows Explorer, browse to your working folder and copy/paste the 
PRJ file associated with this shapefile.

b  Right-click the copied file, and Rename it appropriately, such as 
“myEcoProjection_mmddyyyy.prj”

Results

Three Eco-ready files:

•  Plot List

•  Strata Area 

•  Projection (automatically created in the Define Projection/Reprojection steps above 
as part of the AOI Shapefile)


