ECO GUIDE TO

Importing an Existing Inventory
If you have an existing complete inventory, you have the option to analyze that inventory by
importing the data into Eco following the procedure outlined below. This guide applies to
existing data from complete inventories that at a minimum contain species and diameter at
breast height (dbh). It is currently not possible to import sample plot data into i-Tree Eco.

Formatting Your Data
First, you will need to format your data. i-Tree Eco’s inventory import tool works best with a
properly formatted dataset. This means that existing data should be saved as a specific file type
and include the required data fields. Each data field also has its own formatting requirements
that must be adhered to.

!

Caution
Depending on the available memory on your computer, you may need to
divide large datasets into smaller batches in order for the import process to
function. For example, some users have been unable to import datasets
larger than 50,000 trees. If the software becomes slow, unresponsive, or fails
when importing data, divide your dataset into smaller batches and import
those separately into your Eco project.

Tip
In addition to this guide, information and troubleshooting tips can be found in
these videos and forum post:
Videos:
Importing Inventory Data into i-Tree Eco v6
i-Tree Eco v6 – External Inventory Data Import Troubleshooting Steps
Forum post:
How Can I Troubleshoot Records Not Importing in Eco
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What file type is best?
Save your inventory data as one of the following file types:
•

Excel spreadsheet (.xls or .xlsx)

What data are required?
i-Tree Eco v6.0 requires users to collect only two tree data fields:
•

Species: The species and genus names of each tree assessed.

•

Diameter at breast height (dbh): The tree stem diameter at breast height (4.5 feet
above the ground) for each tree.

!

Caution
i-Tree Eco requires users to input a minimum of two tree data fields, species
and dbh, for complete inventory projects. While this approach allows users
with limited data to run the model, it also has substantial limitations. The
accuracy of ecosystem service estimates can be improved significantly by
providing additional optional tree measurements.
Please read more about these data limitations in the Eco Guide to Data
Limitations.

For users collecting dead trees, an additional data field is required for your existing inventory.
Users must collect:
•

Crown health: Tree crown health estimated as condition or dieback (i.e., dead
branches) of the crown.

The crown health field is used to indicate which sampled trees are dead and which are not.
Dead trees should be given either a 100% dieback or 0% condition designation depending on
which field you decide to provide.
Be aware that some supplemental analyses, such as energy benefits and pest detection,
require certain data to be collected beyond species and DBH. Please refer to the Eco guide,
Data Collection Options for Supplemental Analyses, for more information.
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How do I format each data field?
In addition to the two required data fields (species and dbh), users are allowed to import any or
all of the data shown in Table 1. Each data field has its own formatting requirements.

Caution

!

Required fields, species and dbh, must be entered according to the formatting
requirements in Table 1 or mapped to Eco’s values. Invalid or unmatched
values will result in records being skipped.

Here are several guidelines to keep in mind:
•

Spreadsheet Cell Format - Each column in the spreadsheet that you are importing from
should be formatted prior to importing according to the type of data it contains; mixing
data types within a column may cause inconsistent results. For example, Microsoft Excel
often displays data as numbers but formats them as another category such as text. This
will become apparent during the import process and should be fixed in Excel
beforehand.

•

Field names – Users are not required to edit the field names of their existing data to
match those used by i-Tree Eco; instead, during the import process, users will be asked
to indicate the corresponding Eco field name.

•

Data limits – Eco requires that all values to fall within accepted limits. For fields where
this applies, the limits are included in Table 1. Tree records that do not meet these
limitations will not be imported so it is best to correct issues before importing.

•

Field type – Some Eco fields can be displayed in multiple ways. For example, species
data can be entered as common name, scientific name, or species code. During the
import process users must indicate which field type corresponds to their existing data.
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Data mapping – During the import process user can select “I need to map my source column
values” for certain fields. If you select this option, you will have the opportunity to match each
unique value in the selected column of your data to a value that i-Tree Eco recognizes. For
example, if you have recorded your species data as locally relevant species codes, these codes
do not have to be the same ones that are built into i-Tree Eco. However, they must be mapped
to values Eco recognizes. The option to map values is available for all fields in Table 1. If there
are fields you want to map, the data formatting in Table 1 need not be followed.

Tip
Save Time, Format Data Before Importing!
The data mapping process can be tedious and time consuming when
there are many values to be mapped. We highly recommend that you
format the data you are going to import according to the guidelines in
Table 1. In doing this you will eliminate, or severely limit, the amount of
data that will need to be matched to values that Eco recognizes, which will
likely save you time as mapping data during the import process can be
more time consuming compared to formatting data in Excel.
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Data Fields

Cell Format

Data Specifications and Limits

Species

Text

DBH

Number

Enter as specified in the Eco Field Manual
Lower limit is 0.5 inch, there is not an upper
limit to what Eco will accept.

Required fields

Optional fields
Tree ID

Number

Tree address
Strata
Crew
Survey Date
Status
Land use
Photo ID
Latitude
Longitude
DBH measurement height
DBH measured

Text
Short or
Long Date
Text
General

Number
Text

Street tree/non-street tree

Text

Public/private

Text

Total tree height
Height to live top
Height to crown base
Crown
Crown width
size

Number
Number
Number
Number

Percent crown missing
Crown health
Crown light exposure
Direction
Energy
Distance
Maintenance recommended
Maintenance task
Sidewalk conflict
Utility conflict
Pests (IPED)
User Tree ID
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Number
Number
Number
Number

General

> 0 without duplication.
To import a unique identifier for each tree,
please use the User Tree ID field.
Enter as defined in Project Configuration
none
Long date will be converted to short date.
Planted, Ingrowth, or Unknown
Enter as specified in Project Configuration
none
Decimal degrees if mapping is desired
Decimal degrees if mapping is desired
0.1 to 6 feet
Enter as Yes (Y) or No (N)
Enter as Yes (Y) for street tree or No (N) for
non-street tree
Enter as Yes (Y) for public tree or No (N) for
private tree
0 to 450 feet
0 to 450 feet
0 to height to live top
0 to 300 feet
0%, 100%, and the mid points of 5%
increments (i.e. 0, 3, 8,13…98,100)
Enter as defined in Project Configuration
-1, 0, 1, 2, 3, 4, or 5
1 to 360 degrees
0.1 to 60 feet
Enter as defined in Project Configuration
Enter as defined in Project Configuration
Enter as defined in Project Configuration
Enter as defined in Project Configuration
Enter as defined in IPED Field Manual
none

Using the Complete Inventory Import Function
Having properly formatted your existing inventory, you will now import that data into a new or
existing Eco project. To begin, click on your computer’s Start button > (All) Programs > i-Tree
> i-Tree Eco v6.
To create a new project:
1 Click File > New Project.
2 In the New Project window, select “Complete Inventory” from the project type dropdown list in the upper right corner.
3 Click OK.
4 In the Save Project File As window, browse to the folder where you would like to save
your project.
5 Enter a file name in the space provided.
6 Click Save.
After you create a new project, you will see that i-Tree Eco automatically opens the Project
Definition function of the Project Configuration tab. Configuring your project is one of the first
things that you do when you create an Eco project. This allows you to provide i-Tree Eco with
important information, such as where your study area is located, and what data you will be
collecting. For a complete inventory project where you are importing existing data, all of the
information that you provide here should apply to that existing dataset.
To configure your project:
1 Click on the Project Configuration tab.
2 Click on the Project Definition function.
3 Work through the Project Settings, Location, and Data Collection Options tabs from
left to right.
4 Close the Project Definition function when you are finished by clicking on the OK
button in the upper right corner to save your settings.
5 Work from left to right through the Project Configuration tabs to configure fields and
features relevant to your project.

Tip
While working in Eco, use the on-screen help text in the panel on the left
side of the window. This help text will provide directions for using each
button and function.
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Tip
There are several data fields in the Project Definition > Data Collection
Options action panel that can be defined by the user. For example,
management fields, such as sidewalk and utility conflicts, can be
customized so users can specify values that are relevant to their project.
The values chosen for these fields within the project need reconcile with
the values in the data you will be importing.

To import your existing inventory:
1

Click on the Data tab.

2

Click on the Trees function. (Note: The Import button will become available in the
ribbon.)

3

Click on the Import tool to import your existing tree inventory.

4

In the Data Import Wizard, click Browse.
a
b

Navigate to the file containing your inventory data.
Select the file and click Open.

5

Check the box to signify that the first row of your dataset contains the column headers if
that is true. Otherwise, leave the box unchecked.

6

Confirm that the correct data appears in the preview table and click Next.

7

Match your existing data fields to Eco’s data fields.
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a

Select an inventory column from the table. The column header will appear in the
“Your Source Column” space below the table on the left side.

b

Choose the “Eco Field” from the drop-down list that matches your selected
column.

c

Check the box indicating whether you will need to map your field values to the
Eco field values. (Note: You will be prompted to complete the value mapping
later. See step 9 below.)

d

As previously described, Eco data fields can often be displayed in several ways.
For example, species data can be entered as common name, scientific name, or
species code. For data fields where this applies, a “Field Type” drop-down list will
appear below “Eco Field.” Select the field type that matches your existing data.

e

Repeat steps 7a through 7d until each column that you would like to import has
been matched to the appropriate Eco field.

Tip
Try moving across the columns that contain your data from left to right,
clicking on each one that contains data you want to import. Columns that
contain data you do not want to import can be skipped.

8

Click the Next button at the bottom of the window.

9

For data fields where you indicated the need to map field values (in step 7c above),
match your field values to Eco’s.
a

In the upper table, select a row.

b

In the lower table, the values in the “Your Value” column that are colored green
have been automatically matched to the values in the “Eco Value” column. The
values Eco does not recognize, and you need to map, are colored black in the
Your Value column and the adjacent “Eco Value” is empty. Select a row that you
need to map and click in the “Eco Value” cell. Next, you will either type in a value
Eco will recognize, or if a drop down list appears, choose the “Eco Value” from
the drop-down list that is the best match for “Your Value”. It is possible to change
the values that Eco automatically maps by clicking on the “Eco Value” you want
to change and selecting from the drop down menu that appears.

Tip
Depending on how much data is in the “Eco Value” drop down menu it may
take up to a minute for the menu to become visible. This is particularly true
when mapping species. We suggest you format your data according to the
parameter in Table 1 prior to importing.
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c

Move through the lower table until all of your values have been matched to an
Eco Value. Values that you have matched will appear orange in the Your Value
and Eco Value columns.

d

Repeat steps 9a through 9c until all necessary data fields have been mapped.

10 Click Next.
11 Review the results of your processed data at the top of the Data Import Wizard. This
information will tell you how many records from your inventory data will be imported.
12 When you are satisfied with the data that will be imported, click Finish. (Note: Use the
Back button to return to previous steps for any adjustments.)
After you have completed importing your existing inventory data, you will be able to make use of
i-Tree Eco as described in the User’s Manual. Use the Data tab to view or edit your data, edit
benefit prices, or add annual costs. Use the Reports tab to submit your data for processing,
retrieve your results, and view the results of your i-Tree Eco run. In the Forecast tab you can
model future scenarios for your urban forest. The Support tab contains links to i-Tree support
materials.
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