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Appendix 2: Random Plots Workbook:  
Unstratified Sample

These instructions will help users of all skill levels create a random sample of i-Tree Eco 
plot centers, plot areas, and the associated i-Tree Eco-required data files for their study 
area. ESRI ArcGIS software with the Spatial Analyst extension is used. The instructions 
are generic and applicable with modification to different versions of ArcGIS as well as 
other GIS software in terms of basic operations. 

These instructions comprise three basic steps:

1  Prepare project area data.

2  Generate sample plots.

3  Create Eco-ready output.

When finished, you will have created the following:

• Area-of-interest (AOI) map layer composed of a single (or multi-part) polygon.

• Random sample plot centers point map layer with Eco-required fields added and 

• populated. 

• Sample plot areas polygon map layer. 

• Eco-ready Strata Area text file.

• Eco-ready Plot List text file.

• Eco-ready Projection prj file.

Tips

• The Spatial Analyst extension for ArcGIS is required.

• Field names and types are important.

• Obtain projection system and map unit information from the map data provider first.

• All map data must have valid projection information for proper alignment.

• AOI map data must be in a projection system that uses feet or meters – NOT 
degrees.

• Final Eco-required map units will be metric.
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• AOI examples are polygons such as a city boundary, park areas, or management 
zones. 

• ESRI shapefiles are easiest to use.

• “Pin” open ArcToolbox when starting – pushpin icon, upper right of ArcToolbox 
panel.

• Practice good file management: folders to hold copies of original data, folders to 
hold output, employ logical file naming, etc.

• ArcGIS should add the geoprocessed map layers to the view automatically. If not, 
use the File > Add Data > Add Data… menu to load them.

Project Area Data Preparation

Overview

• Obtain a GIS map layer representing the area-of-interest (AOI) polygon(s) for your 
project area.

• Launch the ArcMap application of ArcGIS.

• Load the AOI map layer into the data view.

• Define the projection/coordinate system of the AOI if needed.

• Reproject the AOI to a system using feet or meters if needed.

• Dissolve the AOI into a single polygon (a single, multi-part polygon if more than 
one polygon).

• Add Eco-required fields and calculate appropriate values for them.

Detailed instructions

1  Obtain an area-of-interest (AOI) polygon from your GIS Department or an online 
resource. Several options can be found here: http://www.esri.com/data/free-data.

2  Launch ArcMap.

3  Save your project with an appropriate name at a new location via the File > Save 
As menu. Save periodically while working to avoid data loss.

4  Use the File > Add Data > Add Data… menu to browse to and load the AOI 
polygon map layer to the current view. 

a  If your data are properly projected, ArcGIS should handle projection 
differences between the AOI and subsequent map layers on-the-fly.

b  If your data lack projection information, an “Unknown Spatial Reference” 
message may appear. Click OK to move past it and use ArcToolbox to 

http://www.esri.com/data/free-data/index.html
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define the projection of the AOI map layer according to your data provider’s 
specifications.  
 
Navigate to ArcToolbox > Data Management Tools > Projections 
and Transformations > Define Projection and complete the Define 
Projection form:
 
For Input Dataset, choose the AOI map layer from the drop-down list.
 
For Coordinate System, click the Properties button to the right. 
 
In the Spatial Reference Properties window that appears, click Select and 
choose the coordinate system indicated by your data provider.

5  If necessary, use ArcToolbox to reproject your AOI map layer to a system using feet 
or meters, ideally selecting a projection system already in use by your organization 
or a commonly used system such as State Plane or UTM in the United States.

6  Navigate to ArcToolbox > Data Management Tools > Projections and 
Transformations > Feature > Project and complete the Project form:

a  For Input Dataset, select the AOI map layer from the drop-down menu. 

b  Input Coordinate System should be grayed out based on your work in the 
previous step or per your data provider. 

c  For Output Dataset or Feature Class, use the Browse button to the 
right and navigate to a suitable location to save the output file and give it a 
name. 

d  For Output Coordinate System, click the Properties button to the right

e  In the Spatial Reference Properties window that appears, click the Select 
button and navigate to the proper coordinate system. 

f  For Geographic Transformation, select the first choice in the drop-down 
list if prompted with an “Undefined Geographic Transformation” message. 

g  Click OK when you’ve completed all the boxes.

7  If your AOI has more than one polygon, you must use ArcToolbox to dissolve them.

a  Navigate to ArcToolbox > Data Management Tools > Generalization > 
Dissolve and complete the Dissolve window:

b  For Input Features, select the projected AOI map layer from the list. 
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c  For Output Feature Class, use the Browse button to navigate to a suitable 
location and give the file a name. 

d  For Dissolve Field, check the data field attribute value that unifies the AOI.  
Example: a “Name” field containing the city name of an AOI, even across 
physically separate city sections. You may need to peruse the layer’s 
attribute table to find this.

e  Leave the Statistics field blank. 

f  Ensure the Create Multipart Features box is checked. 

g  Click OK to finish.

8  Right-click the new dissolved AOI polygon layer, Open Attribute Table and verify 
that there is now a single, multipart polygon present.

9  Use ArcToolbox to add Eco-required fields to the projected, dissolved AOI map 
layer. 

a  Navigate to ArcToolbox > Data Management Tools > Fields > Add Field 
and complete the Add Field form:

b  Under Input Table, select the dissolved AOI map layer from the dropdown 
list.

c  For Field Name, enter:  Strat_ID 

d  For Field Type, select LONG from the drop-down list.

e  Skip the following fields: 

Field Precision

Field Scale

Field Length

Field Alias

Field is Nullable

Field is Required

Field Domain

f  Click OK.

10  Repeat the steps above as follows for these additional fields:

a  Field Name:  Strat_Area  with Field Type: Select DOUBLE.
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b  Field Name:  Strata with Field Type: Select TEXT.

11  Use the attribute table Field Calculator to populate values for the Eco-specific 
fields added to the projected, dissolved AOI map layer. To begin, right-click the 
projected, dissolved AOI map layer and select Open Attribute Table.

a  Right-click the Strat_ID field column heading and select Field Calculator...

b  In the large text entry box below Strat_ID =, enter:  1 

c  Click OK.

d  Repeat for the Strata field.

e  In the large text entry box below Strata =, enter: “Single Strata” (including 
quotes!)

f  Click OK.

g  Right-click the Strat_Area field column heading and select Calculate 
Geometry…

h  For Property: choose Select Area. If this is not available, your AOI map 
layer is not in a projection system using feet or meters; see Steps 4 and 5.

i  For Coordinate System choose Use coordinate system of the data 
source.

j  For Units, select Hectares [ha].

Results

An area-of-interest (AOI) single polygon map layer with Eco-required fields added 
and populated.

• The AOI polygon map layer is now ready to be used for plot generation.

Sample Plot Generation

 Overview

• Run the Create Random Points tool from ArcToolbox for the AOI.

• Add Eco-required fields to the random plots data.

• Calculate field values for the random plots data.

• Buffer the random plots point data to form plot areas.
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Detailed instructions

Use the Create Random Points tool in ArcToolbox to generate the desired number of plots 
for the projected, dissolved AOI.

1  Navigate to ArcToolbox > Data Management Tools > Feature Class > Create 
Random Points.

2  Complete the Create Random Points form:

a  For Output Location, browse to and single-click your working folder to 
select it and click Add.

b  For Output Point Feature Class, type in an appropriate name with a .SHP 
extension. 

c  For Constraining Feature Class, select your projected, dissolved AOI 
polygon map layer.

d  For Number of Points [value or field], enter the desired number of sample 
plots for this selected land cover.

e  Skip the remaining inputs.

f  Click OK. 

Use ArcToolbox to add Eco-required fields to the newly created sample plots point map 
layer.

1  Navigate to ArcToolbox > Data Management Tools > Fields > Add Field.

2  Complete the Add Field form:

a  For Input Table, select the newly created sample plots point map layer 
from the dropdown list.

b  For Field Name, enter:  ID 

c  For Field Type, select LONG from the drop-down list.

d  Skip the following fields: 

Field Precision

Field Scale

Field Length

Field Alias
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Field is Nullable

Field is Required

Field Domain

e  Click OK.

3  Repeat the steps above as follows for these additional fields:

a  Field Name:  LCCode with Field Type: Select SHORT.

b  Field Name:  X_Coord with Field Type: Select DOUBLE.

c  Field Name:  Y_Coord with Field Type: Select DOUBLE.

Use the attribute table Field Calculator to populate values for the Eco-specific fields added 
to the sample plots point map layer in the step above.

1  Right-click the sample plots point map layer and select Open Attribute Table.

2  Right-click the ID field column heading and select Field Calculator...

a  In the large text entry box below ID =, enter:  [FID]+1 

b  Click OK.

3  Repeat step 2 for the LCCode field.

a  In the large text entry box below LCCode =, enter:  1 

4  Right-click the X_Coord field column heading and select Calculate Geometry…

a  For Property: select X Coordinate of Point

b  For Coordinate System choose Use coordinate system of the data 
source

c  For Units, select Meters [m]

d  Click OK.

5  Right-click the Y_Coord field column heading and select Calculate Geometry…

a  For Property: select Y Coordinate of Point

b  For Coordinate System choose Use coordinate system of the data 
source

c  For Units, select Meters [m]
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d  Click OK.

6  To verify the attributes have been correctly modified in the sample plots point map 
layer, right-click the sample plots point map layer in the map layers list, and choose 
Open Attribute Table.

a  Scan through the fields and their values to verify they are correct.

(Optional) Use ArcToolbox to buffer the sample plots point map layer. This step creates 
the plot of your desired survey size around the plot centers and can be used to make field 
data collection plot maps.

1  Navigate to ArcToolbox > Analysis Tools > Proximity > Buffer.

2  Complete the Buffer form:

a  Under Input Features, select the sample plots point map layer from the 
drop-down list.

b  For Output Feature Class, use the Browse button to navigate to a suitable 
location and choose a file name for the resulting map layer.

c  For Distance, in the Linear Unit box, enter the distance value from the list 
below, based on your desired plot size. (The distance is the radius of the 
plot).

Feet:
For 1/5 acre plots: enter: 52.66

For 1/10 acre plots: enter: 37.24

For 1/20 acre plots: enter: 26.33

For 1/100 acre plots: enter: 11.78

Meters:

For 1/5 hectare plots: enter: 25.23

For 1/10 hectare plots: enter: 17.84

For 1/20 hectare plots: enter: 12.62

For 1/100 hectare plots: enter: 5.64

d  Select Feet or Meters as appropriate from the units dropdown

e  Skip the following entries:

Side Type

End Type
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Dissolve Type

Dissolve Field(s)

f  Click OK.

3  The buffered sample points layer is added to the map view automatically; zoom 
in to examine individual plot areas. Note: choose an appropriate equal-area 
projection system in the layers data view properties if your plot areas appear not to 
be circular.

Results 

Sample plots point map layer

• User-defined number of plots randomly spread throughout the AOI

• Plot points assigned with land cover categories

• Eco-required fields added and populated

(Optional) Sample plot areas polygon map layer

Create Eco-Ready Output

 Overview

• Export select fields from the Plot attribute table to a text file.

• Export select fields from the Strata polygons attribute table to a text file.

• Copy and rename the AOI projection file.

Detailed instructions

1  From the Selection menu, choose Clear Selected Features if available to 
unselect all features.

2  Right-click the spatially joined sample plot centers point map layer in the map 
layers list and select Open Attribute Table. 

a  Right-click the FID field and select Turn Field Off.

b  Repeat for all but the ID, LCCode, X_Coord, and Y_Coord fields (added in 
Sample Plot Generation above).

c  Under the upper left Table Options drop-down button, select Export.  

d  Browse to a folder where you wish to save the output file.
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e  For Save the file as type select Text File.

f  Name the export appropriately, such as “myEcoPlots_mmyyyy.txt”.

g  Click No when asked to add the new table to the current map.

3  Open the text file in a simple editor such as Windows Notepad (avoid using word 
processing software due to formatting issues).

a   Use the Search and Replace function to replace each comma with a 
space.

b  Save the file

c  Delete the first line containing the field names: “ID”,”LCCode”,”X_
Coord”,”Y_Coord”

d  Copy and paste these two lines at the top of the file:  
 
$ U4PLLS! 1.3 20040728 1549 
1

e  A properly formatted file will look like this:

$U4PLLS! 1.3 20040728 1549
1
1 1 1199094.600650 2095374.121430
2 1 1202999.760510 2094522.116280
3 1 1207382.288000 2096877.180300
4 1 1198150.473980 2101783.086320
...

4  Right-click the dissolved land cover polygon layer in the map layers list and select 
Open Attribute Table.  

a   Right-click the FID field and select Turn Field Off.

b  Repeat for all but the Strat_ID, Strat_Area, and Strata fields (added in 
Strata Preparation above).

c  Under the Table Options drop-down button, select Export. 

d  Browse to a folder where you wish to save the output file and save as a 
Text File. 

e  Name the export appropriately, such as “myEcoStrata_mmyyyy.txt”.
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f  Click No when asked to add the new table to the current map.

5  Open the text file in a simple editor (avoid using word processing software).

a  Use the Search and Replace function to replace each comma with a 
space.

b  Save the file.

c  Delete the first line containing the field names: “Strat_ID”,”Strat_
Area”,”Strata”

d  Copy and paste these two lines at the top of the file:  

$U4STAR! 1.3 20040728 1549
1

e  A properly formatted file will look like this:

$U4STAR! 1.3 20040728 1549
1
1 15138.785733 “Developed”
2 3187.141038 “Open”
3 217.131072 “Other”
... 

6  Make a copy of the PRJ file associated with your dissolved land cover polygons 
layer. 

a  In Windows Explorer, browse to your working folder and copy/paste the 
PRJ file associated with this shapefile.

b  Right-click the copied file, and Rename it appropriately, such as 
“myEcoProjection_mmddyyyy.prj”

Results

Three Eco-ready files:

• Plot List

• Strata Area 

• Projection (automatically created in the Define Projection/Reprojection steps above 
as part of the AOI Shapefile)


